Weave Software Requirements

Software requirements for installing Weave.

Desktop App Requirements

The Weave Desktop App will be installed on each computer station in your office that needs to access Weave.

Software requirements are:

  • Windows 10 or newer

  • For Mac: OS X Yosemite 10.10 or newer

Note: Windows XP and Windows Vista are no longer supported by Google Chrome or Weave. If you have these operating systems, you’ll need to upgrade to a newer operating system that is on the list above.

Server Requirements

If you signed up for WeavePlus and have a server-based Practice Management Software, we will be doing a small install on your server. Server requirements are:

  • For Servers: Windows Server 2012, or Windows Server 2016
Was this article helpful?
0 out of 5 found this helpful